FAQ Firmware update "killed" transceiver

Discussion in 'X-108' started by Sergei, Jun 19, 2019.

  1. Sergei
    Offline

    Sergei Beginner X-108 Member

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Ratings:
    +0 / 0 / -0
    Rufzeichen/Call:
    kd6cji
    I ran firmware update and now X108G is dead. It does boot in firmware update mode, but not in operation mode. I followed instructions and radio reported that firmware was updated successfully but after restart radio is dead. The caveat here is that I used iMac to do update. I did mount radio as external drive, when I deleted firmware.bin boot screen reported success, then I copied update file from Desktop to external drive and boot screen reported that update was successful. I can try to find a Windows machine and repeat procedure, but so far I can't figure out what the difference might it make. Did anyone tried to update using MacOS?

    Thanks,

    Sergei KD6CJI
     
  2. Sergei
    Offline

    Sergei Beginner X-108 Member

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Ratings:
    +0 / 0 / -0
    Rufzeichen/Call:
    kd6cji
    Update. Plugged into Windows 7 machine, started transceiver in update mode, connect usb cable and windows says Unknown USB Device...
     
  3. OA4LDR
    Offline

    OA4LDR Chef-Boarder X-108 Member

    Messages:
    13
    Likes Received:
    3
    Trophy Points:
    3
    Gender:
    Male
    Ratings:
    +3 / 0 / -0
    Rufzeichen/Call:
    Tito
    Trabaje con Windows! Bajé sus drivers adecuados si es de 32 o 64bits
    Siga los pasos de la actualización y luego finalice desconectar el cable de poder del equipo de la parte trasera por un mínimo y luego volverá a encender el equipo allí aparecerá todo de manera normal! Saludos cordiales desde Lima-Peru OA4LDR 73s
     
  4. Rick Vee
    Offline

    Rick Vee Beginner X-108 Member

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Ratings:
    +0 / 0 / -0
    Rufzeichen/Call:
    4506754
    Did the same thing, everything worked like it supposed to but when i turned it on, black screen and doesnt work anymore!
     
  5. Rick Vee
    Offline

    Rick Vee Beginner X-108 Member

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Ratings:
    +0 / 0 / -0
    Rufzeichen/Call:
    4506754
    You need to install the driver first!
     
  6. Alezis
    Offline

    Alezis Beginner X-108 Member

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0 / -0
    Rufzeichen/Call:
    VA2CST
    Happened on a X108 but a reflash and it did work ok.
     

Share This Page