x-108 bugs Known Bugs and Problems

Discussion in 'X-108' started by hb9eue, May 25, 2015.

  1. Elmar
    Offline

    Elmar Junior Boarder X-108 Member

    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Ratings:
    +0 / 0 / -0
    Rufzeichen/Call:
    DH0GME
    Hi all,
    my TRX makes heavy distortion on SSB even on 13.8V via power supply unit - first thought it would be only on battery at lower voltages, but supply seems to have no impact on this behaviour - any idea?
     
  2. DD5LP
    Offline

    DD5LP Crack-Boarder X-108 Member

    Messages:
    150
    Likes Received:
    10
    Trophy Points:
    18
    Gender:
    Male
    Location:
    Pürgen, Bavaria, Germany
    Home page:
    Ratings:
    +13 / 1 / -0
    Verified User:
    YES
    Rufzeichen/Call:
    DD5LP
    So are you saying the audio tx quality is bad whether on battery or mains supply.

    Check you don't have compression turned full on - the audio in the x108 isn't great ok at 2 but not higher.

    Also make sure your antenna matching is good - if you have RF getting back to the radio the x108 will often take that into the microphone lead and ferrites don't seem to help.
    It could of course be a faulty microphone do you have another microphone that you can try? It must be wired correctly for the connection of course.
    73 Ed
     
    Last edited: May 10, 2021
  3. Elmar
    Offline

    Elmar Junior Boarder X-108 Member

    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Ratings:
    +0 / 0 / -0
    Rufzeichen/Call:
    DH0GME
    Hi Ed,
    thanks for reply!
    I checked compression rate 1:1 and up - power supply over the whole allowed range - clipped a pound of ferrites on every cable, tried (full) battery, switch mode and linear supply and tried on several antennas with ATU and also an EFHF for 40m perfectly matched with common mode choke and a counterpoise.... no hint, what was the root cause.
    Also what is strange, that it isn't always the same level of destortion on different bands.
    And it is independant of the RF level from 0,5...20W (I use my other TRX in shack w/o antenna as test RX)

    In the moment it's something between voodoo and a cold soldering on the PCBA..... absolutly "funny" !!
    Another Mic I don't have by hand, but as mentioned, it's not always the same, but up to now I wasn't able to see something like a thermal issue that would be reproducible....
    (The last open test will be using the rear mic input with a single tone signal to check if the hand-mic is causing the trouble)

    As the TRX was laying unused in my shack some time, might it be a calibration issue? If yes, does someone know if the
    extended settings (F1 on startup) might helpful to tune the correct center frequencies!? ("ringing" filter?!)

    Any hint is highly appreciated!

    73! de Elmar | DH0GME
     
  4. DD5LP
    Offline

    DD5LP Crack-Boarder X-108 Member

    Messages:
    150
    Likes Received:
    10
    Trophy Points:
    18
    Gender:
    Male
    Location:
    Pürgen, Bavaria, Germany
    Home page:
    Ratings:
    +13 / 1 / -0
    Verified User:
    YES
    Rufzeichen/Call:
    DD5LP
    Hi Elmar,
    Another question - does the radio forget the time after it is turned off and on.
    Although this is supposed to be a rechargeable button cell that doesn't need replacement, mine went flat and I had to replace. I had the same problem on my IC 7300 so perhaps there were some bad batches of the battery.
    If you find this fault the battery is a soldered in one and you will need save all those special memory settings as replacing the battery sets the values back to base defaults which won't be right for most rigs.

    73 Ed.
     
  5. Elmar
    Offline

    Elmar Junior Boarder X-108 Member

    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Ratings:
    +0 / 0 / -0
    Rufzeichen/Call:
    DH0GME
    Hi Ed,
    yes, the internal backup battery is down! That was the reason, I was asking for the extended settings which might cause some ringing filters. I've seen the pdf for changing the coin cell (1220?!) but up to now I didn't have dismount the little one.
    What I didn't found so far is a guide to tune the right frequency settings for BFO and IF filter. But you're right, the settings always go back to "some" default, even when I only switch off and on, keeping the power cord plugged in :-(
    I shall go diving into the e(lectronic)bay to get another battery and also will do the test on the rear MIC input...
    ...will last some time.
    It's a pity, that I only have the default values noted down before my firmware update.....
    .....that will cost some time for "try and error" HI!

    I will come back on this issue after my tests and rework of the coin cell!

    73 de Elmar | DH0GME
     
  6. DD5LP
    Offline

    DD5LP Crack-Boarder X-108 Member

    Messages:
    150
    Likes Received:
    10
    Trophy Points:
    18
    Gender:
    Male
    Location:
    Pürgen, Bavaria, Germany
    Home page:
    Ratings:
    +13 / 1 / -0
    Verified User:
    YES
    Rufzeichen/Call:
    DD5LP
    I also had an audio issue when the battery could not keep the memory. In my case it always selected the wrong filter on receive but when the CMOS is wrong lots of things can go wrong.
    73 Ed
     
  7. Elmar
    Offline

    Elmar Junior Boarder X-108 Member

    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Ratings:
    +0 / 0 / -0
    Rufzeichen/Call:
    DH0GME
    YEP - that's also my assumption - Just dismounted the TRX - I'm lucky it's not soldered but with a coin cell holder....
    .... just a simple CR1220 ( never used such a small one before ) I'll first try this and also renew the thermal paste!
    (damn' greasy stuff HI)

    73! de Elmar | DH0GME
     
  8. Ignacio
    Offline

    Ignacio Professional-Boarder X-108 Member

    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Ratings:
    +0 / 0 / -0
    Rufzeichen/Call:
    TI3IES
    I updated my X108G a few months ago with the latest firmware I found, and I noticed that after using the SWR feature the s - meter bar disappears.
     
  9. Elmar
    Offline

    Elmar Junior Boarder X-108 Member

    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Ratings:
    +0 / 0 / -0
    Rufzeichen/Call:
    DH0GME
    Hi Ed,
    the small little coin cell helped, HI - I was able to do the calibration in the F1 menue - just tested on 40m and got a report with good audio !
    TU fer ur assistance,
    73! de Elmar | DH0GME
     
  10. AndyB
    Offline

    AndyB Junior Boarder X-108 Member

    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Ratings:
    +0 / 0 / -0
    Rufzeichen/Call:
    G0LLX
    Hi,
    My X108G has the battery problem so I'm looking at replacing the battery with a new one of whatever I find inside.
    It appears there are 2 versions of battery .. I don't know what is in mine.

    However, I have removed the outer brackets and front panel but can't see anyway into the radio .. I can't find instructions to what I'm attempting .. can you offer any guidance ?

    Many thanks,


    Andy B
     
  11. DD5LP
    Offline

    DD5LP Crack-Boarder X-108 Member

    Messages:
    150
    Likes Received:
    10
    Trophy Points:
    18
    Gender:
    Male
    Location:
    Pürgen, Bavaria, Germany
    Home page:
    Ratings:
    +13 / 1 / -0
    Verified User:
    YES
    Rufzeichen/Call:
    DD5LP
    Hi Andy,
    As well as the screws on the ends, the boards are also attached to the case on the bottom as it is used as the heatsink. If I remember correctly there are four (short) screws in the bottom. Take the knobs off the front (one needs an allen key, the other - the larger one, simply pulls off. Now the whole radio should come out of the back of the case.

    The battery is at one corner and is soldered to the board. If looking for a replacement try Sinotel in the UK.
    73 Ed.
     
    • Like Like x 1
  12. AndyB
    Offline

    AndyB Junior Boarder X-108 Member

    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Ratings:
    +0 / 0 / -0
    Rufzeichen/Call:
    G0LLX
    Many thanks Ed, I appreciate your reply.
    I have removed the screws and the unit slides nice and easy out. Located the battery and it is indeed the version that is soldered to the board. I shall now check out Sinotel to source a replacement and see if that fixes the problem, which tbh I could live with .. it's just annoying. Best 73's,

    Andy B / G0LLX
     
  13. AndyB
    Offline

    AndyB Junior Boarder X-108 Member

    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Ratings:
    +0 / 0 / -0
    Rufzeichen/Call:
    G0LLX
    Hi Ed,
    I have looked into Sinotel and they don't recognise the part number, so perhaps I need to look at alternative components but of the same form factor.

    Can you tell me what the characteristics of the battery are .. i.e. what its voltage is and what its current rating needs to be. So I have found a battery: MS621FE, which is 3v and rated at 5.5mAh .. but I don't know if this will be any good for the X108G ??

    Many thanks,

    Andy B / G0LLX
     
  14. DD5LP
    Offline

    DD5LP Crack-Boarder X-108 Member

    Messages:
    150
    Likes Received:
    10
    Trophy Points:
    18
    Gender:
    Male
    Location:
    Pürgen, Bavaria, Germany
    Home page:
    Ratings:
    +13 / 1 / -0
    Verified User:
    YES
    Rufzeichen/Call:
    DD5LP
    I've replied via private email to your email address from qrz.com.
    73 Ed.
     
    • Like Like x 1

Share This Page