FAQ Firmware for the X108G

Discussion in 'X-108' started by Norbie, Dec 28, 2021.

  1. Norbie
    Offline

    Norbie Beginner X-108 Member

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Location:
    Kingman, AZ USA
    Ratings:
    +0 / 0 / -0
    Rufzeichen/Call:
    KJ6ZD
    This is just a simple question. My HAM buddy acquired a X108G on some flea market. One day he came with a newer? version of the firmware and promptly the transceiver got hosed. The transmitter doesn't do the most important thing, it doesn't transmit anymore. The finals are biased and draw current. The rest of the transceiver appears to work. It just doesn't transmit. Prior to the FW update, it did in fact transmit. I am suspecting either the wrong version or corrupted FW.
    The serial number of the transceiver is XG00078, which maybe one of the first TRX rolled out.
    The confusing part is the "INDOOR" and "OUTDOOR" designation.
    I have absolutely no idea which of them applies to this rig. Don't even know what the difference would be, since the rig can operate indoor or outdoor without modification, hi, hi.
    Is there anyone that knows what to flash into this rig and what version it should be?
    Thanks,
    KJ6ZD, 73
     
  2. Ignacio
    Offline

    Ignacio Professional-Boarder X-108 Member

    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Ratings:
    +0 / 0 / -0
    Rufzeichen/Call:
    TI3IES
  3. santana
    Offline

    santana Beginner X-108 Member

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Ratings:
    +0 / 0 / -0
    Rufzeichen/Call:
    GM4BNU
     
  4. santana
    Offline

    santana Beginner X-108 Member

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Ratings:
    +0 / 0 / -0
    Rufzeichen/Call:
    GM4BNU
    Hello, I have just obtained another x108g oled early serial nr in first 150,the previous owner tried to update it and wiped out the firmware.Being of advanced years and not very good with pc,s I was reluctant to try and sort it out.
    However i did manage to download and feed in to the rig the latest firmware--but on reset I get just a blank screen will I have to find and load down the original programming and then put in the update???
     

Share This Page