X-108 Info x108g outdoor - AM mode problem

Discussion in 'X-108' started by Bartek, Sep 21, 2017.

  1. Bartek
    Offline

    Bartek Beginner X-108 Member

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Ratings:
    +0 / 0 / -0
    Rufzeichen/Call:
    SP3BTA
    Has anyone had a problem with AM mode? in my case after switching PTT in AM mode- radio transmit
    predicted power (for example 10W) but correspondent hear buzzing. When I start modulating to microphone
    power goes down to 2-5W and fluctuates almost like on SSB mode, when I stop talking power rise to 10W and buzzing is back
    It was also measured on dummy load and both - battery and power supply (rather not power or antenna issue)
    in SSB mode everything seems to be OK
     
  2. Krazypcs
    Offline

    Krazypcs Junior Boarder X-108 Member

    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Ratings:
    +0 / 0 / -0
    Rufzeichen/Call:
    M6HTF
    I had the same problem but only had it while running on battery. After endless checks, i found that it was a current issue.
    For some odd ball reason, replacing battery with a different one solved the problem.
     
  3. Richard67
    Offline

    Richard67 Beginner X-108 Member

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Ratings:
    +0 / 0 / -0
    Rufzeichen/Call:
    MM6RBX
    my radio goes from 10w on transmit to 2 watt as I speak is that normal
     
  4. Richard67
    Offline

    Richard67 Beginner X-108 Member

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Ratings:
    +0 / 0 / -0
    Rufzeichen/Call:
    MM6RBX
    also I have noted my output is proper with only 10.7 volts at 13.2 volts or above my 10.7 it gradually puts out lower power
     

Share This Page